contrib: integrate RPM spec

Remove OpenSUSE bug report link, set version to @VERSION@, make it build
with CentOS 8 etc.

Related: OS#4550
Change-Id: Idfe04c2e2609763387d1309f059c390b8e7ae938
changes/05/18305/2
Oliver Smith 2 years ago
parent d0156fd6a8
commit c10cb81593
  1. 2
      .gitignore
  2. 1
      configure.ac
  3. 12
      contrib/osmo-pcu.spec.in

2
.gitignore vendored

@ -64,3 +64,5 @@ doc/manuals/generated/
doc/manuals/osmomsc-usermanual.xml
doc/manuals/common
doc/manuals/build
contrib/osmo-pcu.spec

@ -256,4 +256,5 @@ AC_OUTPUT(
doc/manuals/Makefile
contrib/Makefile
contrib/systemd/Makefile
contrib/osmo-pcu.spec
Makefile)

@ -12,24 +12,22 @@
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: osmo-pcu
Version: 0.8.0.126
Version: @VERSION@
Release: 0
Summary: Osmocom GPRS Packet Control Unit (PCU)
License: GPL-2.0-only
Group: Productivity/Telephony/Servers
URL: https://osmocom.org/projects/osmopcu/wiki/OsmoPCU
URL: https://osmocom.org/projects/osmopcu
Source: %{name}-%{version}.tar.xz
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: gcc-c++
BuildRequires: libtool
BuildRequires: pkgconfig >= 0.20
%if 0%{?suse_version}
BuildRequires: systemd-rpm-macros
%endif
BuildRequires: pkgconfig(libosmocore) >= 1.1.0
BuildRequires: pkgconfig(libosmogb) >= 1.1.0
BuildRequires: pkgconfig(libosmogsm) >= 1.1.0
@ -55,6 +53,7 @@ make %{?_smp_mflags}
%install
%make_install
%if 0%{?suse_version}
%preun
%service_del_preun %{name}.service
@ -66,6 +65,7 @@ make %{?_smp_mflags}
%post
%service_add_post %{name}.service
%endif
%check
make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
Loading…
Cancel
Save