osmo-iuh/debian/rules

25 lines
919 B
Makefile
Executable File

#!/usr/bin/make -f
DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
# main packaging script based on dh7 syntax
%:
dh $@ --with autoreconf
# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
override_dh_strip:
dh_strip -plibosmo-hnbap0 --dbg-package=libosmo-hnbap-dbg
dh_strip -plibosmo-ranap7 --dbg-package=libosmo-ranap-dbg
dh_strip -plibosmo-rua0 --dbg-package=libosmo-rua-dbg
dh_strip -plibosmo-sabp1 --dbg-package=libosmo-sabp-dbg
# Print test results in case of a failure
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
override_dh_compress:
dh_compress -X.pdf