smalltalk
/
osmo-st-all
Archived
1
0
Fork 0
This repository has been archived on 2022-02-17. You can view files and clone it, but cannot push or open issues or pull requests.
osmo-st-all/debian/rules

38 lines
997 B
Makefile
Executable File

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
#
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
#
# Modified to make a template file for a multi-binary package with separated
# build-arch and build-indep targets by Bill Allombert 2001
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
# This has to be exported to make some magic below work.
export DH_OPTIONS
%:
dh $@
override_dh_auto_install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
$(MAKE) GST_PACKAGE_ARGS="--destdir $(CURDIR)/debian/tmp" install
override_dh_installdeb:
perl -w debian/dh_makestarlibs -i -V
dh_installdeb -i
override_dh_gencontrol:
perl -w debian/dh_stardeps -i
perl -w debian/dh_fixstars -i
dh_gencontrol -i