cmd2: Constrain version to >= 1.3.0 but < 2.0.0

2.0.0 introduces several incompatible changes, see
https://github.com/python-cmd2/cmd2/blob/master/CHANGELOG.md
as well as https://github.com/python-cmd2/cmd2/issues/1120

As we want to be able to use what distributions ship, let's stay
with 1.x for now.  If piip is used, use 1.5

Change-Id: Iecc953269d5ae9ed9f31b829743c63bdfd29fa61
changes/48/24648/1
Harald Welte 2 years ago
parent fb50621570
commit 1a4e9fd163
  1. 2
      README.md
  2. 2
      contrib/jenkins.sh
  3. 2
      requirements.txt
  4. 2
      setup.py

@ -37,7 +37,7 @@ Please install the following dependencies:
- pyscard
- serial
- pytlv
- cmd2
- cmd2 >= 1.3.0 but < 2.0.0
- jsonpath-ng
- construct
- bidict

@ -19,7 +19,7 @@ virtualenv -p python3 venv --system-site-packages
. venv/bin/activate
pip install pytlv
pip install pyyaml
pip install cmd2
pip install cmd2==1.5
pip install jsonpath-ng
pip install construct
pip install bidict

@ -1,7 +1,7 @@
pyscard
serial
pytlv
cmd2
cmd2==1.5
jsonpath-ng
construct
bidict

@ -12,7 +12,7 @@ setup(
"pyscard",
"serial",
"pytlv",
"cmd2 >= 1.3.0",
"cmd2 >= 1.3.0, < 2.0.0",
"jsonpath-ng",
"construct >= 2.9",
"bidict",

Loading…
Cancel
Save