contrib/jenkins.sh: pylint v2.15 is unstable, pin v2.14.5

pylint v2.15 is crashing, let's fall-back to a known to work v2.14.5.

Change-Id: Ie29be6ec6631ff2b3d8cd6b2dd9ac0ed8f505e4f
Related: https://github.com/PyCQA/pylint/issues/7375
Related: OS#5668
changes/39/29239/1
Vadim Yanitskiy 3 months ago
parent 59f3b1154f
commit 12175d3588
  1. 2
      contrib/jenkins.sh

@ -36,7 +36,7 @@ python -m unittest discover -v -s tests/
# Ignore E0401: import-error
# pySim/utils.py:276: E0401: Unable to import 'Crypto.Cipher' (import-error)
# pySim/utils.py:277: E0401: Unable to import 'Crypto.Util.strxor' (import-error)
pip install pylint
pip install pylint==2.14.5 # FIXME: 2.15 is crashing, see OS#5668
python -m pylint --errors-only \
--disable E1102 \
--disable E0401 \

Loading…
Cancel
Save