Browse Source

increase required libosmocore version

osmo-remsim depends on a variety of modern libosmocore features,
and now that libosmocore 1.6.0 has been tagged, we can finally depend
on a more recent minimum version.

Change-Id: Ic3cb86b5be524f15d118bcb7ec1947608fbbb034
changes/76/26476/1
Harald Welte 8 months ago
parent
commit
507070dcb4
  1. 2
      configure.ac
  2. 2
      contrib/osmo-remsim.spec.in
  3. 2
      debian/control

2
configure.ac

@ -33,7 +33,7 @@ if test "x$PKG_CONFIG_INSTALLED" = "xno"; then
fi
PKG_PROG_PKG_CONFIG([0.20])
PKG_CHECK_MODULES(OSMOCORE, libosmocore >= 1.3.0)
PKG_CHECK_MODULES(OSMOCORE, libosmocore >= 1.6.0)
PKG_CHECK_MODULES(OSMOGSM, libosmogsm >= 0.11.0)
PKG_CHECK_MODULES(OSMOABIS, libosmoabis >= 0.8.0)

2
contrib/osmo-remsim.spec.in

@ -31,7 +31,7 @@ BuildRequires: systemd-rpm-macros
%endif
BuildRequires: pkgconfig(libasn1c) >= 0.9.30
BuildRequires: pkgconfig(libosmoabis)
BuildRequires: pkgconfig(libosmocore) >= 0.11.0
BuildRequires: pkgconfig(libosmocore) >= 1.6.0
BuildRequires: pkgconfig(libosmogsm) >= 0.11.0
BuildRequires: pkgconfig(libosmosim)
BuildRequires: pkgconfig(libpcsclite)

2
debian/control vendored

@ -9,7 +9,7 @@ Build-Depends: debhelper (>= 9),
pkg-config,
osmo-gsm-manuals-dev,
libcsv-dev,
libosmocore-dev (>= 1.3.0),
libosmocore-dev (>= 1.6.0),
libosmo-abis-dev,
libosmo-simtrace2-dev,
libpcsclite-dev,

Loading…
Cancel
Save