bladeRF: check libbladeRF version before compiling

pull/2/head
Robert Ghilduta 4 years ago committed by Eric Wild
parent 6a22db7568
commit f6a8992856
  1. 4
      cmake/Modules/FindLibbladeRF.cmake

@ -1,5 +1,9 @@
if(NOT LIBBLADERF_FOUND)
pkg_check_modules (LIBBLADERF_PKG libbladeRF)
if (LIBBLADERF_PKG_FOUND AND LIBBLADERF_PKG_VERSION VERSION_LESS "2")
message( FATAL_ERROR "Install version 2 or greater of libbladeRF."
" Current version ( ${LIBBLADERF_PKG_VERSION} ) is out of date." )
endif()
find_path(LIBBLADERF_INCLUDE_DIRS NAMES libbladeRF.h
PATHS
${LIBBLADERF_PKG_INCLUDE_DIRS}

Loading…
Cancel
Save