Bump version: 0.3.0.5-5364-dirty → 0.4.0

Change-Id: Id9d5ef30ddbeb644cfbd98383a8764435576cbfe
changes/37/28437/1 0.4.0
Pau Espin 5 months ago
parent 5364393417
commit bddebaecb2
  1. 8
      configure.ac
  2. 8
      contrib/osmo-pcap.spec.in
  3. 13
      debian/changelog
  4. 2
      debian/control

@ -157,11 +157,11 @@ AC_SUBST([PCAP_LIBS])
AC_SUBST([PCAP_CFLAGS])
dnl checks for libraries
PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 1.6.0)
PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 1.7.0)
# libosmogb: needed for osmocom/gprs includes
PKG_CHECK_MODULES(LIBOSMOGB, libosmogb >= 1.6.0)
PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 1.6.0)
PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 1.6.0)
PKG_CHECK_MODULES(LIBOSMOGB, libosmogb >= 1.7.0)
PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 1.7.0)
PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 1.7.0)
PKG_CHECK_MODULES(LIBZMQ, libzmq >= 3.2.2)
PKG_CHECK_MODULES(LIBGNUTLS, gnutls)

@ -29,10 +29,10 @@ BuildRequires: systemd-rpm-macros
%endif
BuildRequires: pkgconfig
BuildRequires: pkgconfig(gnutls)
BuildRequires: pkgconfig(libosmocore) >= 1.6.0
BuildRequires: pkgconfig(libosmogb) >= 1.6.0
BuildRequires: pkgconfig(libosmogsm) >= 1.6.0
BuildRequires: pkgconfig(libosmovty) >= 1.6.0
BuildRequires: pkgconfig(libosmocore) >= 1.7.0
BuildRequires: pkgconfig(libosmogb) >= 1.7.0
BuildRequires: pkgconfig(libosmogsm) >= 1.7.0
BuildRequires: pkgconfig(libosmovty) >= 1.7.0
BuildRequires: pkgconfig(libzmq) >= 3.2.2
%{?systemd_requires}

13
debian/changelog vendored

@ -1,3 +1,16 @@
osmo-pcap (0.4.0) unstable; urgency=medium
[ Pau Espin Pedrol ]
* client: Increase wqueue transmit length
* client: Log wqueue capacity when failing to enqueue
* client: Add 'wqueue max-length <0-4294967295>' VTY command
* .gitignore: blacklist configure~
[ Harald Welte ]
* update git URLs (git -> https; gitea)
-- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 28 Jun 2022 17:36:44 +0200
osmo-pcap (0.3.0) unstable; urgency=medium
[ Vadim Yanitskiy ]

2
debian/control vendored

@ -7,7 +7,7 @@ Build-Depends: debhelper (>= 7.0.50~),
autotools-dev,
libpcap0.8-dev,
pkg-config,
libosmocore-dev (>= 1.6.0),
libosmocore-dev (>= 1.7.0),
libgnutls28-dev,
libzmq3-dev (>= 3.2.2)
Standards-Version: 3.9.1

Loading…
Cancel
Save