Add a pkg-config manifest for libosmogapk

In order to make pkg-config 'see' the libosmogapk, a corresponding
package description is required. For more details, see:

https://autotools.io/pkgconfig/file-format.html
changes/78/5778/1^2
Vadim Yanitskiy 5 years ago
parent 5f941573b0
commit 40d59f14a2
  1. 3
      .gitignore
  2. 3
      Makefile.am
  3. 1
      configure.ac
  4. 11
      libosmogapk.pc.in

3
.gitignore vendored

@ -3,7 +3,7 @@ autoscan-2.*.log
configure.scan
# autoreconf by-products
*.in
Makefile.in
aclocal.m4
autom4te.cache/
@ -18,6 +18,7 @@ m4/
missing
# configure by-products
*.pc
.deps
Makefile

@ -1,6 +1,9 @@
AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
ACLOCAL_AMFLAGS = -I m4
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libosmogapk.pc
AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
SUBDIRS = include

@ -17,6 +17,7 @@ AC_CONFIG_FILES([
libgsmhr/Makefile
include/Makefile
include/gsmhr/Makefile
libosmogapk.pc
])
# Options

@ -0,0 +1,11 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
libdir=@libdir@
includedir=@includedir@
Name: Osmocom GSM Audio Transcoding Library
Description: C Utility Library
Requires: libosmocore, libosmocodec
Version: @VERSION@
Libs: -L${libdir} -losmogapk
Cflags: -I${includedir}/
Loading…
Cancel
Save