osmo-msc-latest: install libdbd-sqlite3

Fix osmo-msc crash at start up:
<0009> db.c:621 Failed to create database connection to sqlite3 db 'sms.db'; Is the sqlite3 database driver for libdbi installed on this system?
DB: Failed to init database: sms.db

It would be better if the Debian package pulled in this dependency
automatically, see OS#3771.

Related: OS#3767
Change-Id: Ia816aed8dd3b86f44f4454af89cec6f0b9d55dd1
changes/20/12720/1
Oliver Smith 4 years ago
parent 0c4eba94e5
commit 2279152bb2
  1. 4
      osmo-msc-latest/Dockerfile

@ -14,11 +14,13 @@ RUN apt-key add /tmp/Release.key && \
rm /tmp/Release.key && \
echo "deb " $OSMOCOM_REPO " ./" > /etc/apt/sources.list.d/osmocom-latest.list
# libdbd-sqlite3: workaround for OS#3771
ADD $OSMOCOM_REPO/Release /tmp/Release
RUN apt-get update && \
apt-get install -y --no-install-recommends \
osmo-msc \
telnet && \
telnet \
libdbd-sqlite3 && \
apt-get clean
WORKDIR /tmp

Loading…
Cancel
Save