contrib: integrate RPM spec

Remove OpenSUSE bug report link, set version to @VERSION@, make it build
with CentOS 8 etc.

Related: OS#4550
Change-Id: I387b41b6c524cd3f6baad7e89b4b6b347d9998ac
changes/11/18311/2
Oliver Smith 2 years ago
parent afb705309f
commit d02c8f72b1
  1. 2
      .gitignore
  2. 1
      configure.ac
  3. 11
      contrib/osmo-sip-connector.spec.in

2
.gitignore vendored

@ -33,3 +33,5 @@ doc/manuals/generated/
doc/manuals/osmomsc-usermanual.xml
doc/manuals/common
doc/manuals/build
contrib/osmo-sip-connector.spec

@ -146,6 +146,7 @@ AC_OUTPUT(
doc/manuals/Makefile
contrib/Makefile
contrib/systemd/Makefile
contrib/osmo-sip-connector.spec
doc/Makefile
doc/examples/Makefile
Makefile)

@ -12,22 +12,21 @@
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: osmo-sip-connector
Version: 1.4.0.0
Version: @VERSION@
Release: 0
Summary: MNCC to SIP bridge for osmo-nitb
License: AGPL-3.0-or-later AND GPL-2.0-or-later
Group: Productivity/Telephony/Servers
URL: http://openbsc.osmocom.org/
URL: https://osmocom.org/projects/osmo-sip-conector
Source: %{name}-%{version}.tar.xz
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
BuildRequires: pkgconfig >= 0.20
%if 0%{?suse_version}
BuildRequires: systemd-rpm-macros
%endif
BuildRequires: pkgconfig(libosmocore) >= 1.0.0
BuildRequires: pkgconfig(libosmogsm) >= 1.0.0
BuildRequires: pkgconfig(libosmovty) >= 1.0.0
@ -51,6 +50,7 @@ make %{?_smp_mflags}
%install
%make_install
%if 0%{?suse_version}
%preun
%service_del_preun %{name}.service
@ -62,6 +62,7 @@ make %{?_smp_mflags}
%post
%service_add_post %{name}.service
%endif
%check
make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
Loading…
Cancel
Save