Commit Graph

44 Commits (467fc5728d638239b0257c0e9e60a0e516826e8c)

Author SHA1 Message Date
Harald Welte 467fc5728d switch sqlite3 to single-threaded mode 9 months ago
Pau Espin b7f97ea8a0 Bump version: 1.7.0.43-aefbf-dirty → 1.8.0 1 year ago
Pau Espin 59764b6f3e Bump version: 1.6.1.98-cad22-dirty → 1.7.0 2 years ago
Harald Welte e188010474 debian/control: Recommend installation of osmo-mgw 2 years ago
Pau Espin 24a885608d Support setting rt-prio and cpu-affinity mask through VTY 2 years ago
Vadim Yanitskiy a908b43e59 debian/control: change maintainer to the Osmocom team / mailing list 2 years ago
Pau Espin 6a0c4d9d24 Bump version: 1.5.0.72-6e72-dirty → 1.6.0 3 years ago
Pau Espin b0504632c5 Fix dependency version requirements 4 years ago
Vadim Yanitskiy f523f22899 debian/control: add missing libdbd-sqlite3 to Build-Depends 4 years ago
Oliver Smith a2273f5f1d debian: create -doc subpackage with pdf manuals 4 years ago
Pau Espin 0dad52d0b7 debian/control: Fix typo 4 years ago
Oliver Smith 0dfa61e39e debian: depend on libdbd-sqlite3 4 years ago
Harald Welte ca292dd607 debian: depend on libsctp-dev 4 years ago
Harald Welte 1ea6baf1ec Remove local libgsupclient; Use libosmo-gsup-client from osmo-hlr 5 years ago
Maxim Suraev 753c15de2f Migrate from OpenSSL to osmo_get_rand_id() 5 years ago
Harald Welte 633e58a196 Debian: require minimum versions of packages we depend on 5 years ago
Harald Welte 6a9d9baef5 Depend on both libosmo-sigtran-dev and libosmo-sccp-dev 5 years ago
Harald Welte f45c34ddab Debian: Depend on libosmo-sigtran-dev, not libsomo-sccp-dev! 5 years ago
Harald Welte 9588450f92 Debian: Add proper description for packages. 5 years ago
Harald Welte bde463d781 Debian: Build with enabled SMPP support 5 years ago
Harald Welte 69c5ae0923 Debian: remove obsolete Dependencies 5 years ago
Neels Hofmeyr a81ee7c3b8 debian: fix dependency to mgcp library 5 years ago
Neels Hofmeyr d6d90ce259 debian: fix web and VCS links, tweak osmo-msc.install 5 years ago
Alexander Couzens 4d1ee5eaf0 rework debian packages support 5 years ago
Holger Hans Peter Freyther 3f940fc9ee debian: Require libgtp-dev after the SO version bump 6 years ago
Holger Hans Peter Freyther 76f048a1fd debian: Install header and source file to different directory 6 years ago
Maxim Suraev 34f012639d Turn some compiler warnings into errors 6 years ago
Ruben Undheim c8fc41c2f6 deb: unbreak nightly builds 6 years ago
Neels Hofmeyr 98bc7fa50d Revert "Turn some warnings into errors" 6 years ago
Maxim Suraev fd161ccce8 Turn some warnings into errors 6 years ago
Maxim Suraev 5fa8b083cc Integrate Debian packaging changes 6 years ago
Neels Hofmeyr e5e78c21bb gtphub: add to debian build 7 years ago
Ciaby 92360b15e3 Add SMPP support in the debian build, include libsmpp34-dev as a dependency. 8 years ago
Holger Hans Peter Freyther 8fc568466c debian: Require ares for the SGSN and GGSN resolving 8 years ago
Holger Hans Peter Freyther 0190d790b6 debian: Add libssl-dev for the NAT 8 years ago
Holger Hans Peter Freyther 446f8403d1 debian: Fix dependencies pointed out by lintian 8 years ago
Holger Hans Peter Freyther b396b69cb2 debian: Do not depend on shared libraries directly 8 years ago
Holger Hans Peter Freyther adc17268fc debian: meas2pcap requires libpcap-dev unconditionally 8 years ago
Jacob Erlbeck b194862b62 debian: Fix dependencies 8 years ago
Max a5cae441e2 Fix some packaging mistakes detected by lintian. 9 years ago
Holger Hans Peter Freyther 65f7427e02 debian: Build debug packages for each of the target packages 9 years ago
Holger Hans Peter Freyther 93fda87cf8 debian: Make the package creation work on debian squeeze (stable) 10 years ago
Holger Hans Peter Freyther e0b5972d30 debian: We require libdbi-sqlite3 for running the tests 10 years ago
Holger Hans Peter Freyther e600eed7fa debian: Move debian directory to ease building packages 10 years ago
Eric Butler dd68fcaeee Fix libdbi package dependency 11 years ago
Eric Butler a73ca05db6 Update debian package. 11 years ago
Harald Welte 2c67f47dba debian: make more dependencies explicit in 'control' file 13 years ago
Harald Welte 305e2906aa debian: don't buld arch-independent packages with executables in them 13 years ago
Harald Welte ba43969832 debian: don't use override_dh_* for lenny compatibility 13 years ago
Harald Welte 5c55c4901d debian: add build dependency to pkg-config 13 years ago