increase libsmpp34 version requirement to 1.12

Only 1.12 contains some of the #defines that we're using with recent
commits.

Change-Id: I3743b10a1a5d2f1d42a61204273c1d00dc22b600
changes/63/3663/2
Harald Welte 6 years ago committed by Neels Hofmeyr
parent 586e6819eb
commit 2d23e901a0
  1. 2
      configure.ac

@ -66,7 +66,7 @@ AC_SUBST(osmo_ac_build_bsc)
AC_ARG_ENABLE([smpp], [AS_HELP_STRING([--enable-smpp], [Build the SMPP interface])],
[osmo_ac_build_smpp="$enableval"],[osmo_ac_build_smpp="no"])
if test "$osmo_ac_build_smpp" = "yes" ; then
PKG_CHECK_MODULES(LIBSMPP34, libsmpp34 >= 1.10)
PKG_CHECK_MODULES(LIBSMPP34, libsmpp34 >= 1.12)
AC_DEFINE(BUILD_SMPP, 1, [Define if we want to build SMPP])
fi
AM_CONDITIONAL(BUILD_SMPP, test "x$osmo_ac_build_smpp" = "xyes")

Loading…
Cancel
Save