debian: Add dependency to libosmo-mgcp-client-dev

Since Change-Id Ia2882b7ca31a3219c676986e85045fa08a425d7a, osmo-bsc
uses osmo-mgw and utilizes libosmo-mgcp-client to talk to it, so
let's make sure the Debian control file states that dependency.

Unfortuantely, this still won't make the osmo-bsc debian package
build again, as in fact the above commit uses symbols not even present
in 1.0.0 or 1.1.0 releases of libosmo-mgcp-client :(  So we first
need a new release of that library, and we need to update the
configure.ac and debian/control version requirements in osmo-bsc
before this is fixed.  This needs to be automatized in the future.

Change-Id: I41a0378d069f5383904cf92cc415c19beba26168
changes/47/4747/1
Harald Welte 5 years ago
parent 6a12c76196
commit ec6bba5b7f
  1. 3
      debian/control

3
debian/control vendored

@ -17,7 +17,8 @@ Build-Depends: debhelper (>=9),
libosmo-sigtran-dev (>= 0.8.0),
libosmo-abis-dev (>= 0.3.2),
libosmo-netif-dev (>= 0.1.0),
libosmo-legacy-mgcp-dev (>= 0.0.1)
libosmo-legacy-mgcp-dev (>= 0.0.1),
libosmo-mgcp-client-dev (>= 1.0.0)
Standards-Version: 3.9.8
Vcs-Git: git://git.osmocom.org/osmo-bsc.git
Vcs-Browser: https://git.osmocom.org/osmo-bsc/

Loading…
Cancel
Save