remove obsolete dependency on libosmo-sccp

We only use libosmo-sigtran these days, so we can remove the depdency
to the old libosmo-sccp from osmo-bsc.  We don't use LIBOSMO_SCCP_*
variables in any Makefile.am, nor do we #include <osmocom/sccp/...>
anywhere [anymore].

Change-Id: Ie478016ffb6e767ba10968c1ee2ab98db15a45a3
Related: OS#2601
changes/68/23068/2
Harald Welte 2 years ago
parent 6505f692d4
commit 0ed69da597
  1. 1
      configure.ac
  2. 1
      contrib/osmo-bsc.spec.in
  3. 1
      debian/control

@ -58,7 +58,6 @@ PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 1.5.0)
PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 1.1.0)
PKG_CHECK_MODULES(LIBOSMONETIF, libosmo-netif >= 1.1.0)
PKG_CHECK_MODULES(LIBOSMOSIGTRAN, libosmo-sigtran >= 1.4.0)
PKG_CHECK_MODULES(LIBOSMOSCCP, libosmo-sccp >= 1.4.0)
PKG_CHECK_MODULES(LIBOSMOMGCPCLIENT, libosmo-mgcp-client >= 1.8.0)
dnl checks for header files

@ -33,7 +33,6 @@ BuildRequires: systemd-rpm-macros
BuildRequires: pkgconfig(libcrypto) >= 0.9.5
BuildRequires: pkgconfig(libosmo-mgcp-client) >= 1.8.0
BuildRequires: pkgconfig(libosmo-netif) >= 1.1.0
BuildRequires: pkgconfig(libosmo-sccp) >= 1.4.0
BuildRequires: pkgconfig(libosmo-sigtran) >= 1.4.0
BuildRequires: pkgconfig(libosmoabis) >= 1.1.0
BuildRequires: pkgconfig(libosmocore) >= 1.5.0

1
debian/control vendored

@ -13,7 +13,6 @@ Build-Depends: debhelper (>=9),
libcdk5-dev,
libtalloc-dev,
libosmocore-dev (>= 1.5.0),
libosmo-sccp-dev (>= 1.4.0),
libosmo-sigtran-dev (>= 1.4.0),
libosmo-abis-dev (>= 1.1.0),
libosmo-netif-dev (>= 1.1.0),

Loading…
Cancel
Save