GNU Radio block for interfacing with various radio hardware
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
Robert Ghilduta f6a8992856 bladeRF: check libbladeRF version before compiling 4 months ago
apps osmocom_fft: make it work with gr >= 3.9 qwidget/pyqwidget 4 months ago
cmake bladeRF: check libbladeRF version before compiling 4 months ago
docs Replace swig with pybind11 for gr3.9 master compat 2 years ago
grc add xtrx support 2 years ago
include/osmosdr Remove Doxygen warnings. 2 years ago
lib switch to gr-funcube 4 months ago
python Remove Doxygen warnings. 2 years ago
.gitignore add a reasonable .gitignore 4 months ago
AUTHORS Add support for FreeSRP 6 years ago
CMakeLists.txt switch to gr-funcube 4 months ago
COPYING update license file to GPL v3 as in source 11 years ago
MANIFEST.md updated MANIFEST.md 7 years ago
README switch to gr-funcube 4 months ago

README

While primarily being developed for the OsmoSDR hardware, this block
as well supports:

* FUNcube Dongle / Pro+ through gr-funcube
* RTL2832U based DVB-T dongles through librtlsdr
* RTL-TCP spectrum server (see librtlsdr project)
* SDRplay RSP through SDRplay API library
* gnuradio .cfile input through libgnuradio-blocks
* RFSPACE SDR-IQ, SDR-IP, NetSDR (incl. X2 option)
* AirSpy Wideband Receiver through libairspy
* CCCamp 2015 rad1o Badge through libhackrf
* Great Scott Gadgets HackRF through libhackrf
* Nuand LLC bladeRF through libbladeRF library
* Ettus USRP Devices through Ettus UHD library
* Fairwaves UmTRX through Fairwaves' module for UHD
* Fairwaves XTRX through libxtrx
* Red Pitaya SDR transceiver (http://bazaar.redpitaya.com)
* FreeSRP through libfreesrp

By using the OsmoSDR block you can take advantage of a common software api in
your application(s) independent of the underlying radio hardware.

For installation and usage guidelines please read the documentation available
at http://sdr.osmocom.org/trac/wiki/GrOsmoSDR

For the impatient :) a short excerpt:

The Gnu Radio block requires a recent gnuradio (>= v3.7) to be installed.

Before building the block you have to make sure that all the dependencies
(see list of supported devices above) you are intend to work with are
properly installed. The build system of gr-osmosdr will recognize them and
enable specific source/sink components thereafter.

Please note: prior pulling a new version from git and compiling it,
please do a "make uninstall" first to properly remove the previous version.

Building with cmake:

git clone git://git.osmocom.org/gr-osmosdr
cd gr-osmosdr/
mkdir build
cd build/
cmake ../
make
sudo make install
sudo ldconfig

NOTE: The osmocom blocks will appear under 'Sources' and 'Sinks' categories
in GRC menu.